Google Chrome Update

If you use Google Chrome you should update to version 23.0.1271.95. Google released this update to fix multiple vulnerabilities that could cause denial of service and even execute code on your computer. No computer is safe from these attacks, unless of course if you don’t have Chrome installed. This includes Mac, Windows, and yes even ChromeFrame. If you would like to read more check out the article.

Recent Entries

php web stats Website Security Test